2
Vote

"None" element name for include (filename) should be "Content"

description

When running the ClickToBuild.cmd file a bunch of errors occur for CKEditor (see screenshots for a more colorful version):

"C:\Projects\DarkSky\OrchardMarket\Orchard.proj" (Build target) (1) ->
(ValidateProjectFiles target) ->
C:\Projects\DarkSky\OrchardMarket\src\Orchard.Web\Modules\CKEditor\CKEditor.c
sproj(339,6): error : "None" element name for include "Placement.info" should b
e "Content". [C:\Projects\DarkSky\OrchardMarket\Orchard.proj]
C:\Projects\DarkSky\OrchardMarket\src\Orchard.Web\Modules\CKEditor\CKEditor.c
sproj(340,6): error : "None" element name for include "Scripts\ckeditor.htacce
ss" should be "Content". [C:\Projects\DarkSky\OrchardMarket\Orchard.proj]
C:\Projects\DarkSky\OrchardMarket\src\Orchard.Web\Modules\CKEditor\CKEditor.c
sproj(341,6): error : "None" element name for include "Scripts\ckeditor\ckedito
r.pack" should be "Content". [C:\Projects\DarkSky\OrchardMarket\Orchard.proj]
C:\Projects\DarkSky\OrchardMarket\src\Orchard.Web\Modules\CKEditor\CKEditor.c
sproj(342,6): error : "None" element name for include "Scripts\ckeditor\ckedito
r.php" should be "Content". [C:\Projects\DarkSky\OrchardMarket\Orchard.proj]
C:\Projects\DarkSky\OrchardMarket\src\Orchard.Web\Modules\CKEditor\CKEditor.c
sproj(343,6): error : "None" element name for include "Scripts\ckeditor\ckedito
r_php4.php" should be "Content". [C:\Projects\DarkSky\OrchardMarket\Orchard.pro
j]
C:\Projects\DarkSky\OrchardMarket\src\Orchard.Web\Modules\CKEditor\CKEditor.c
sproj(344,6): error : "None" element name for include "Scripts\ckeditor\ckedito
r_php5.php" should be "Content". [C:\Projects\DarkSky\OrchardMarket\Orchard.pro
j]
33 Warning(s)
6 Error(s)

I will be providing a patch and attach it to this work item.

file attachments

comments

edtruant wrote Jan 20, 2014 at 3:54 PM

Any news on this issue?
I'm also experiencing the same problem and can't understand which is the point.
The thing that worries me most is that it is highlighted as 'error', and I'm going throughout
a build/deploy process for the first time. Little bit disoriented.

edtruant wrote Jan 20, 2014 at 3:56 PM