CKEditor is undefined

Oct 24, 2011 at 3:44 AM

I have installed CKEditor. It works on my own machine but on production server, the CKEditor is not seen. IE reports an error in ckeditor.js line 343 (CKEditor is undefined). what may cause this error?

Coordinator
Oct 26, 2011 at 5:19 PM
  • Which Orchard versions do you have on your machine and on the server?
  • Which OrchardCKEditor versions do you have on your machine and on the server?
  • Did you install from the gallery or upload via FTP?
Feb 14, 2012 at 7:22 PM

I am having the same problem.  I installed CKEditor from the Gallery.  It works fine on my local development environment.  I have TinyMCE disabled.  When I move to production it does not show the CKEditor.  it shows no editor.....

 

I then also tried to install from gallery on Production Server and got the same issue.  It seams to be installed and as I have a dependent Module "FAQ" when I diasble CKeditor the FAQ also becomes disabled.  That tells me CKeditor was enabled....

 

I have Orchard latest version of 1.3.10 on both Dev and Prod

I have latest CKEditor - Version: 1.0.9.2 on both Dev and Prod

Installed from Gallery.

 

Thank you for ur assistance

Feb 14, 2012 at 8:02 PM

This is the compile time error.....

 

Error 1 The type or namespace name 'CKEditor' could not be found (are you missing a using directive or an assembly reference?)

 c:\Users\XYZ\AppData\Local\Temp\Temporary ASP.NET Files\root\fcae5007\29e94a0b\App_Web_22fyjaqu.0.cs 36

Coordinator
Feb 15, 2012 at 12:14 PM

This isn't the same error as the OP ... but it's something I've seen in another thread ... and I'm wondering if there's a problem in how the CKEditor project is defined that could be causing it. Orchard should be automatically compiling the module so this error should never happen, it's very strange. I'll let you know if I find anything or if there's anything else you can try to make it work. Unfortunately it looks like a difficult error to reproduce especially as it's only happening on production! Are there any differences you're aware of between your environments, e.g. is production running in medium trust or anything like that?

Feb 16, 2012 at 11:22 PM

Thanks for reply.....

I was not able to debug it and ended up using the TinyMceDeluxe Editor on Prod..  It is not that good but works for now.  I would like to use CKEditor if possible...

Orchard does compile automatically and when posted on PROD I get no Editor..  So I decided to open project in VS 10 and debug.  It is then that I saw that there is a namespace issue....  so may be assembly is missing or a reference is missing somewhere and when on PROD orchard runs it skips past the error. 

I even did an install from the gallery on PROD to see if that would help...  But no luck. 

It does work on my DEV enviornment.....  The hosting is at Arvixe and I have other app hosted there that I do not have issue with.  This is the first Orchard Website. 

Coordinator
Feb 17, 2012 at 9:33 AM

That error is coming from a .cshtml file which simply includes a line:

@using CKEditor.Services;

This namespace definitely exists within the module so it's not a reference issue. Can I get you to try the latest source from here on codeplex instead of the gallery version, I made some minor changes to the project, or I'm wondering if it's just a problem with the gallery package?