CKEditor Body Part dark background

Sep 27, 2011 at 1:40 PM

Hello,

I´m having a problem with CKeditor and Body Part.
I have a Content type which is composed by 2 Contrib Html fields and a Body Part, when i try to create new content or edit the existing one, the Ckeditor on the Body the text area has Dark Background,  on the other 2 Html fields the background is ok.

Thank´s,

Nuno.

Oct 2, 2011 at 4:00 PM

Hello again,

I´ve digging and digging, i think i found the problem, The CKeditor on the Body Part is getting the background of my customized theme.

Is there any way to override this, i mean on the editor view (dashboard) so that CKeditor gets a white backgroung?

As you now there is no shape tracing in dasboard, how can i create an alternate in order to override the body part.

Any idea how i could solve this?

 

Thank´s

Nuno.

Coordinator
Oct 5, 2011 at 12:40 PM

Hi,

The CKEditor module by default uses your theme's stylesheet (Site.css) in the editor area - so you get true WYSIWYG editing (as opposed to default styles which won't represent your site's styles).

You can adjust this in the Settings->CKEditor section of the Orchard Dashboard. You can either specify a different stylesheet, if you want to customise it for the editing area, or you can specify none to use the default styles.

By the way, I've just committed a fix for the HtmlField so the Id will be correct.

Coordinator
Oct 5, 2011 at 1:43 PM

By the way - another advantage of using this feature is that CKEditor can automatically populate your styles menu by parsing your Site.css - so it's recommended to leave this feature active, and fix up your Site.css so it works how you expect (or create a separate version of it for CKEditor).